10462查看/33回复/收藏

admin

2017-2-17 16:30:17

1#
准确的说应该是调用多图,如果是一张图,直接设置封面即可,就不需要费这劲了。
网上也有方法,不过我不喜欢他们的方式。
代码可以直接写在模板forumdisplay_list.htm里,有不同数量不同样式。
11.png
以默认模板为例:
打开模板forum/forumdisplay_list.htm,找到83行左右:
  1. <!--{loop $_G['forum_threadlist'] $key $thread}-->
复制代码
在其下增加
  1. <!--{eval $tbid = DB::result(DB::query("SELECT tableid FROM ".DB::table('forum_attachment')." WHERE `tid`= '$thread[tid]'"));}-->
  2. <!--{if $tbid}-->
  3. <!--{eval $picount = DB::fetch_all("SELECT aid FROM ".DB::table('forum_attachment_'.$tbid.'')." WHERE `tid`= '$thread[tid]' AND `isimage`=1;");}-->
  4. <!--{eval $picnum = count($picount);}-->
  5. <!--{if $picnum < 3}-->
  6. <!--{eval $litpicnum = '1';}-->
  7. <!--{elseif $picnum > 2 && $picnum < 6}-->
  8. <!--{eval $litpicnum = '3';}-->
  9. <!--{elseif $picnum > 5}-->
  10. <!--{eval $litpicnum = '6';}-->
  11. <!--{/if}-->
  12. <!--{eval $covers = DB::fetch_all("SELECT attachment,aid,description FROM ".DB::table('forum_attachment_'.$tbid.'')." WHERE `tid`= '$thread[tid]' AND `isimage`=1 LIMIT 0,$litpicnum;");}-->
  13. <!--{/if}-->
复制代码
再查找
  1. <!-- end of table "forum_G[fid]" branch 1/3 -->
复制代码
其上最近的</tr>之后增加
  1. <!--{if $tbid}-->
  2. <tr>
  3. <td></td>
  4. <td></td>
  5. <td colspan="4">
  6. <!--{loop $covers $thecover}-->
  7. <!--{if $litpicnum == 1}-->
  8. <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  9. <font class="z">This is what it is like to be with Trump.</font>
  10. <!--{else}-->
  11. <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  12. <!--{/if}-->
  13. <!--{/loop}-->
  14. </td>
  15. </tr>
  16. <!--{/if}-->
复制代码
再找到
  1. <!--{if !$thread['forumstick'] && ($thread['isgroup'] == 1 || $thread['fid'] != $_G['fid'])}-->
  2. <!--{if $thread['related_group'] == 0 && $thread['closed'] > 1}-->
  3. <!--{eval $thread[tid]=$thread[closed];}-->
  4. <!--{/if}-->
  5. <!--{if $groupnames[$thread[tid]]}-->
  6. <span class="fromg xg1"> [{lang from}: <a href="forum.php?mod=group&fid={$groupnames[$thread[tid]][fid]}" target="_blank" class="xg1">{$groupnames[$thread[tid]][name]}</a>]</span>
  7. <!--{/if}-->
  8. <!--{/if}-->
复制代码
其下增加
  1. <!--{if $tbid && !$picnum == 0}--><span style="color:red;"><!--{$picnum}-->P</span><!--{/if}--></a>
复制代码
结束。

具体的图片显示多少这里↓,<3显示1,>2且<6显示3,>5显示6。
  1. <!--{if $picnum < 3}-->
  2. <!--{eval $litpicnum = '1';}-->
  3. <!--{elseif $picnum > 2 && $picnum < 6}-->
  4. <!--{eval $litpicnum = '3';}-->
  5. <!--{elseif $picnum > 5}-->
  6. <!--{eval $litpicnum = '6';}-->
  7. <!--{/if}-->
复制代码
这个是匆忙写的,没注意有没有逻辑漏洞,如有错请提出。

后面具体的样式是这段↓
  1. <!--{if $litpicnum == 1}-->
  2. <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  3. <font class="z">This is what it is like to be with Trump.</font>
  4. <!--{else}-->
  5. <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  6. <!--{/if}-->
复制代码
如果图片数量等于1,后面带个摘要。
否则图片横排铺开。具体数量会按上面的显示。

通常情况下,两种样式即可,1图和多图,即1图显示在左右,多图在下面铺开。
如果多种样式,<!--{if $litpicnum == 数量}-->此数量时的表现形式</if>
当然,这的数量$litpicnum是受上面的代码中与$picnum关系的限定。
$picnum是实际总数量,$litpicnum是经过判断后允许显示的数量。

要下班了,写的差不多啦,stop here!

[tem]20170218[/tem]
才知道一个鬼问题,不需要查询附件索引表,附件分表id就是帖子id最后一位。
33 回帖

frankxue

2017-2-17 17:07:33

2#
先赞一个再研究,厉害!

frankxue

2017-2-18 00:03:38

3#
试了试,果然都ok,就是有个小问题,“无图帖子”调用图片出了点问题,本来是无图帖子,却调用了临近上1条帖子的全部图片……

admin

2017-2-18 00:49:24

4#
frankxue 发表于 2017-2-18 00:03
试了试,果然都ok,就是有个小问题,“无图帖子”调用图片出了点问题,本来是无图帖子,却调用了临近上1条 ...

我这没有你说的问题。
你试试给<tr></tr>部分外层加上<!--{if $covers}--><!--{/if}-->
就是
  1.     <!--{if $covers}-->
  2. <tr>
  3.     <td></td>
  4.     <td></td>
  5.     <td>
  6.     <!--{loop $covers $thecover}-->
  7.     <!--{if $litpicnum == 1}-->
  8.     <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  9.     <font class="z">This is what it is like to be with Trump.</font>
  10.     <!--{else}-->
  11.     <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  12.     <!--{/if}-->
  13.     <!--{/loop}-->
  14.     </td>
  15.     </tr>
  16. <!--{/if}-->
复制代码
这样如果这个帖子没图片附件,这个<tr>就不让它显示。

frankxue

2017-2-18 11:14:53

5#
admin 发表于 2017-2-18 00:49
我这没有你说的问题。
你试试给部分外层加上
就是

清空帖子后,我重新测试了下,问题好像是这样的:正常情况下,咱们这个代码是没问题的,包括0图、1图、10图等都正常,但是在某个帖子有“新人贴、置顶、精华、热门”等标签的时候,就出现“图片错调”的问题。再具体点的问题描述比如,我注册了个新账号,发了个“0图新人贴”,系统自动打上了“新人贴”标签,结果它就自动调取了附近一条“1图”帖子的图,再比如,我把一条“0图”帖子全局置顶,然后之后发布的所有0图帖子,都开始调用附近的帖子的图片。我猜测,咱们是不是要加个什么判断,去除“新人贴、置顶、精华、热门”等标签的影响?

admin

2017-2-18 12:44:24

6#
frankxue 发表于 2017-2-18 11:14
清空帖子后,我重新测试了下,问题好像是这样的:正常情况下,咱们这个代码是没问题的,包括0图、1图、10 ...

嗯嗯,确实有问题。
我这看的问题是:当有置顶帖时,下面的第一个普通帖子会和上面的置顶帖一样调用图片。
其余的都正常。
测试了下,用if $covers判断不行,换成if $tbid
图片数量显示代码换成:
  1. <!--{if $tbid && !$picnum == 0}--><span style="color:red;"><!--{$picnum}-->P</span><!--{/if}--></a>
复制代码
图片loop部分换成:
  1. <!--{if $tbid}-->
  2. <tr>
  3. <td></td>
  4. <td></td>
  5. <td>
  6. <!--{loop $covers $thecover}-->
  7. <!--{if $litpicnum == 1}-->
  8. <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  9. <font class="z">This is what it is like to be with Trump.</font>
  10. <!--{else}-->
  11. <a href="forum.php?mod=viewthread&tid=$thread[tid]" class="z pipe" title="$thecover[aid]"><img src="data/attachment/forum/$thecover['attachment']" width="100" height="100"/></a>
  12. <!--{/if}-->
  13. <!--{/loop}-->
  14. </td>
  15. </tr>
  16. <!--{/if}-->
复制代码
1.jpg

frankxue

2017-2-18 15:05:34

7#
admin 发表于 2017-2-18 12:44
嗯嗯,确实有问题。
我这看的问题是:当有置顶帖时,下面的第一个普通帖子会和上面的置顶帖一样调用图片 ...

嗯啊,刚才试了试,果然都ok了,楼主果然牛逼!

何日君再来

2017-4-16 09:42:43

8#
不知道能不能实现调用外链图片

admin

2017-4-16 11:28:07

9#
何日君再来 发表于 2017-4-16 09:42
不知道能不能实现调用外链图片
我的空间足够,没用过外链图片。
方法应该是从post表的message里提取出图片。搜preg_match_all

何日君再来

2017-4-16 11:34:22

10#
admin 发表于 2017-4-16 11:28
我的空间足够,没用过外链图片。
方法应该是从post表的message里提取出图片。搜preg_match_all

迫切希望老大有时间就试试
1234下一页
您需要登录后才可以回帖 登录 | 注册
高级模式